package/gupnp-dlna: disable introspection
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 15 Mar 2020 15:02:57 +0000 (16:02 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 15 Mar 2020 15:35:03 +0000 (16:35 +0100)
Build will fail if gobject-introspection is built before gupnp-dlna:
  GISCAN   GUPnPDLNAGst-2.0.gir
Couldn't find include 'Gst-1.0.gir' (search path: '['/home/buildroot/autobuild/run/instance-1/output-1/host/bin/../mipsel-buildroot-linux-gnu/sysroot/usr/bin/../share/gir-1.0', '.', '/home/buildroot/autobuild/run/instance-1/output-1/host/share', 'gir-1.0', '/home/buildroot/autobuild/run/instance-1/output-1/host/share/gir-1.0', '/usr/share/gir-1.0']')

Fixes:
 - http://autobuild.buildroot.org/results/829a84b37db7d9141785bfe2eec2dd0e6d3310f1

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/gupnp-dlna/gupnp-dlna.mk

index 6f9ff8a58c716331e359414908ff9ec7fd99d610..85d30b7cd230f2a738c81db5cf6f28bfd2181038 100644 (file)
@@ -15,7 +15,9 @@ GUPNP_DLNA_LICENSE_FILES = COPYING
 GUPNP_DLNA_INSTALL_STAGING = YES
 GUPNP_DLNA_DEPENDENCIES = host-pkgconf libglib2 libxml2
 
-GUPNP_DLNA_CONF_OPTS = --disable-legacy-gstreamer-metadata-backend
+GUPNP_DLNA_CONF_OPTS = \
+       --disable-introspection \
+       --disable-legacy-gstreamer-metadata-backend
 
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BASE),y)
 GUPNP_DLNA_CONF_OPTS += --enable-gstreamer-metadata-backend