package/libraw: add optional support for jasper
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 30 Jan 2016 16:17:14 +0000 (17:17 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 31 Jan 2016 13:20:47 +0000 (14:20 +0100)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libraw/libraw.mk

index a4ab92f04ebf30b76e56ed5f650dbb804fb0addd..106c52c487762c78d5d77076bce952ad9c451a4d 100644 (file)
@@ -19,4 +19,11 @@ LIBRAW_CONF_OPTS += \
 LIBRAW_LICENSE = LGPLv2.1 or CDDL 1.0 or LibRaw Software License 27032010
 LIBRAW_LICENSE_FILES = LICENSE.LGPL LICENSE.CDDL LICENSE.LibRaw.pdf README
 
+ifeq ($(BR2_PACKAGE_JASPER),y)
+LIBRAW_CONF_OPTS += --enable-jasper
+LIBRAW_DEPENDENCIES += jasper
+else
+LIBRAW_CONF_OPTS += --disable-jasper
+endif
+
 $(eval $(autotools-package))