projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b1dab16
)
nodejs: disable ssl2 and ssl3 when openssl is not built
author
Fabio Porcedda
<fabio.porcedda@gmail.com>
Tue, 11 Nov 2014 15:21:03 +0000
(16:21 +0100)
committer
Peter Korsgaard
<peter@korsgaard.com>
Tue, 11 Nov 2014 20:41:13 +0000
(21:41 +0100)
The nodejs version 0.10.33 is compiled with SSLv2 and SSLv3 protocol
support by default so it fails to build if the package openssl was not
built.
To fix this build failure disable SSLv2 and SSLv3 protcol suppport if
the openssl package is not built.
Fixes:
http://autobuild.buildroot.net/results/
e1fb34818ff1167aa008b4011befb9fd14c81293
http://autobuild.buildroot.net/results/
8b72b0c311f2f7f7430aca5f7cca1f7d82d1c213
http://autobuild.buildroot.net/results/
e5f87dc635e0e6a6d1cc234529a433e12d810097
http://autobuild.buildroot.net/results/
3c4a5be556cfbd0d0e632757887ebc2f1de64bba
Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/nodejs/nodejs.mk
patch
|
blob
|
history
diff --git
a/package/nodejs/nodejs.mk
b/package/nodejs/nodejs.mk
index 312aaa9d0265f07a1853f51b6c88ac6633f41ca5..32e19b795f26f4adf91a640d89d5113604f83dbc 100644
(file)
--- a/
package/nodejs/nodejs.mk
+++ b/
package/nodejs/nodejs.mk
@@
-75,7
+75,8
@@
define NODEJS_CONFIGURE_CMDS
--prefix=/usr \
--without-snapshot \
--shared-zlib \
- $(if $(BR2_PACKAGE_OPENSSL),--shared-openssl,--without-ssl) \
+ $(if $(BR2_PACKAGE_OPENSSL),--shared-openssl,\
+ --without-ssl --without-ssl2 --without-ssl3) \
$(if $(BR2_PACKAGE_NODEJS_NPM),,--without-npm) \
--without-dtrace \
--without-etw \