package/efl: use liblz4 from lz4 package
authorRomain Naour <romain.naour@gmail.com>
Sun, 4 Dec 2016 12:22:05 +0000 (13:22 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 4 Dec 2016 14:32:29 +0000 (15:32 +0100)
Efl libraries bundle a copy of liblz4 which is also provided by
lz4 Buildroot package. Switch to liblz4 from lz4 package.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/efl/Config.in
package/efl/efl.mk

index 69b0dcfb3965668bd7f6502a9d4f958a829665f8..5d687e85bd4833b2340c89680bc16219398e99d2 100644 (file)
@@ -16,6 +16,7 @@ config BR2_PACKAGE_EFL
        select BR2_PACKAGE_LIBCURL # Ecore_con_url, runtime dependency
        # https://phab.enlightenment.org/T2728
        select BR2_PACKAGE_LUAJIT # Lua support broken
+       select BR2_PACKAGE_LZ4
        select BR2_PACKAGE_UTIL_LINUX
        # libblkid is part of required tools, see EFL's README.
        select BR2_PACKAGE_UTIL_LINUX_LIBBLKID
index bdf304d3c7caa56782fcf9dda502be1dee465e8a..6ddd454e9b1602e1aac73f629a895e136cc94d1c 100644 (file)
@@ -20,7 +20,7 @@ EFL_LICENSE_FILES = \
 EFL_INSTALL_STAGING = YES
 
 EFL_DEPENDENCIES = host-pkgconf host-efl host-luajit dbus freetype \
-       jpeg luajit udev util-linux zlib
+       jpeg luajit lz4 udev util-linux zlib
 
 # Configure options:
 # --disable-lua-old: build elua for the target.
@@ -28,6 +28,7 @@ EFL_DEPENDENCIES = host-pkgconf host-efl host-luajit dbus freetype \
 # --disable-sdl: disable sdl2 support.
 # --disable-spectre: disable spectre image loader.
 # --disable-xinput22: disable X11 XInput v2.2+ support.
+# --enable-liblz4: use liblz4 from lz4 package.
 # --with-doxygen: disable doxygen documentation
 EFL_CONF_OPTS = \
        --with-edje-cc=$(HOST_DIR)/usr/bin/edje_cc \
@@ -43,6 +44,7 @@ EFL_CONF_OPTS = \
        --disable-spectre \
        --disable-xinput22 \
        --disable-wayland \
+       --enable-liblz4 \
        --with-doxygen=no
 
 # Disable untested configuration warning.