package: add libev
authorYegor Yefremov <yegor_sub1@visionsystems.de>
Mon, 8 Aug 2011 14:55:25 +0000 (16:55 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 10 Sep 2011 15:12:19 +0000 (17:12 +0200)
Signed-off-by: Bernhard Roth <broth@roth-itk.de>
Signed-off-by: Yegor Yefremov <yegor_sub1@visionsystems.de>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/libev/Config.in [new file with mode: 0644]
package/libev/libev.mk [new file with mode: 0644]

index c4cecfa5b83eba5031f01fb88405c4c017fdbfc4..bcdf4210125ff529d8a4ccd31651e6a8f7437586 100644 (file)
@@ -342,6 +342,7 @@ source "package/libcap/Config.in"
 source "package/libdaemon/Config.in"
 source "package/libelf/Config.in"
 source "package/libevent/Config.in"
+source "package/libev/Config.in"
 source "package/libffi/Config.in"
 source "package/libglib2/Config.in"
 source "package/libnspr/Config.in"
diff --git a/package/libev/Config.in b/package/libev/Config.in
new file mode 100644 (file)
index 0000000..71abe77
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LIBEV
+       bool "libev"
+       help
+         Userspace library for handling asynchronous notifications
+
+         http://software.schmorp.de/pkg/libev.html
diff --git a/package/libev/libev.mk b/package/libev/libev.mk
new file mode 100644 (file)
index 0000000..b0db123
--- /dev/null
@@ -0,0 +1,11 @@
+#############################################################
+#
+# libev
+#
+#############################################################
+LIBEV_VERSION = 4.04
+LIBEV_SOURCE = libev-$(LIBEV_VERSION).tar.gz
+LIBEV_SITE = http://dist.schmorp.de/libev/
+LIBEV_INSTALL_STAGING = YES
+
+$(eval $(call AUTOTARGETS,package,libev))