package/mpv: wayland support needs wayland-protocols
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 9 Aug 2019 17:26:37 +0000 (19:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 9 Aug 2019 20:05:03 +0000 (22:05 +0200)
The dependency for wayland-protocols was added with version 0.28.0:
https://github.com/mpv-player/mpv/commit/68f9ee7e0b3fdddfa42fa11a15d9ae84460d5e19#diff-dc6134e3d3c869a052520d86f46371dc

Fixes:
http://autobuild.buildroot.net/results/d5c/d5c5a31bc422defdd64ff0b0ca975bcd605f22be/
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mpv/Config.in
package/mpv/mpv.mk

index 69810038f19bbd06682b2d2c054811261256fb47..32910f2245753bf55e00127290ade3a12fda508f 100644 (file)
@@ -8,6 +8,7 @@ config BR2_PACKAGE_MPV
        select BR2_PACKAGE_FFMPEG
        select BR2_PACKAGE_FFMPEG_SWSCALE
        select BR2_PACKAGE_ZLIB
+       select BR2_PACKAGE_WAYLAND_PROTOCOLS if BR2_PACKAGE_WAYLAND
        # Select xkbcommon for wayland to avoid being mysterious
        select BR2_PACKAGE_LIBXKBCOMMON if BR2_PACKAGE_WAYLAND
        # Select all necessary X11 dependencies if X.org is enabled
index dfc33ea986aa42434da9b54033db9733240e64fa..f92b604c28996cb9b4db0c3fd2a6e9e982f6d0dc 100644 (file)
@@ -197,7 +197,7 @@ endif
 # wayland support
 ifeq ($(BR2_PACKAGE_WAYLAND),y)
 MPV_CONF_OPTS += --enable-wayland
-MPV_DEPENDENCIES += libxkbcommon wayland
+MPV_DEPENDENCIES += libxkbcommon wayland wayland-protocols
 else
 MPV_CONF_OPTS += --disable-wayland
 endif