dbus-triggerd: new package
authorArnaud Rébillout <rebillout@syscom.ch>
Thu, 27 Mar 2014 07:39:59 +0000 (08:39 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 29 Mar 2014 17:53:18 +0000 (18:53 +0100)
dbus-triggerd is a little daemon that can monitor dbus events, match
them against some watch-expressions, then trigger shell-commands.

It can be used in any situation where dbus-interaction is needed, and
shell script is preferred over other languages.

[Thomas: also pass $(TARGET_MAKE_ENV) in the environment.]

Signed-off-by: Arnaud Rébillout <rebillout@syscom.ch>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/dbus-triggerd/Config.in [new file with mode: 0644]
package/dbus-triggerd/dbus-triggerd.mk [new file with mode: 0644]

index 1932353f47718d1b6fe4c6238184119bd11d6418..8c2c70002524bba9ac4831eb64013d86b097dfdc 100644 (file)
@@ -273,6 +273,7 @@ source "package/dbus/Config.in"
 source "package/dbus-cpp/Config.in"
 source "package/dbus-glib/Config.in"
 source "package/dbus-python/Config.in"
+source "package/dbus-triggerd/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/devmem2/Config.in"
 endif
diff --git a/package/dbus-triggerd/Config.in b/package/dbus-triggerd/Config.in
new file mode 100644 (file)
index 0000000..a39f911
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_DBUS_TRIGGERD
+       bool "dbus-triggerd"
+       depends on BR2_USE_MMU # fork(), dbus
+       depends on BR2_TOOLCHAIN_HAS_THREADS # dbus
+       depends on BR2_PACKAGE_DBUS
+       help
+         dbus-triggerd is a tool to trigger shell-commands upon receiving
+         a given dbus-signal.
+
+         http://gareus.org/oss/dbustriggerd/start
+
+comment "dbus-triggerd needs a toolchain w/ threads"
+       depends on BR2_USE_MMU
+       depends on BR2_PACKAGE_DBUS
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/dbus-triggerd/dbus-triggerd.mk b/package/dbus-triggerd/dbus-triggerd.mk
new file mode 100644 (file)
index 0000000..48d5fb2
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# dbus-triggerd
+#
+################################################################################
+
+DBUS_TRIGGERD_VERSION = ba3dbec805cb707c94c54de21666bf18b79bcc09
+DBUS_TRIGGERD_SITE = git://rg42.org/dbustriggerd.git
+DBUS_TRIGGERD_LICENSE = GPLv2+
+DBUS_TRIGGERD_DEPENDENCIES = host-pkgconf dbus
+
+define DBUS_TRIGGERD_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) all
+endef
+
+define DBUS_TRIGGERD_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) DESTDIR="$(TARGET_DIR)" -C $(@D) install
+endef
+
+$(eval $(generic-package))