package/pkg-generic: handle host-tar as an extract dependency
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 24 Mar 2018 14:20:03 +0000 (15:20 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 25 Mar 2018 15:43:20 +0000 (17:43 +0200)
This moves the host-tar dependency handling from
DEPENDENCY_HOST_PREREQ to an extract dependency.

To achieve that, check-host-tar.mk fills in the
BR2_TAR_HOST_DEPENDENCY variable with host-tar if building a host-tar
is needed. The name BR2_TAR_HOST_DEPENDENCY has been chosen because it
matches the name BR2_CMAKE_HOST_DEPENDENCY already used in
check-host-cmake.mk.

The BR2_TAR_HOST_DEPENDENCY is added to all packages, except host-tar
itself (obviously) and host-skeleton, because we depend on
host-skeleton to install host-tar properly in HOST_DIR.

In addition, we modify tar.mk to explicitly build host-tar without
ccache: since ccache source code is available as a tarball, ccache
will obviously depend on host-tar if the system tar is insufficient.

Finally, to make things really clean, we also add
$(BR2_TAR_HOST_DEPENDENCY) to the dependencies of the tar filesystem
format, since it requires tar, so we'd better make sure we have a
suitable tar.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Tested-by: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
fs/tar/tar.mk
package/pkg-generic.mk
package/tar/tar.mk
support/dependencies/check-host-tar.mk

index e39c2fdbf1e347a473511d4b834f2912047882ea..68149e9eb748ce121dcee382204cc5b5d8a0c6d4 100644 (file)
@@ -6,6 +6,8 @@
 
 TAR_OPTS := $(call qstrip,$(BR2_TARGET_ROOTFS_TAR_OPTIONS))
 
+ROOTFS_TAR_DEPENDENCIES = $(BR2_TAR_HOST_DEPENDENCY)
+
 define ROOTFS_TAR_CMD
        (cd $(TARGET_DIR); find -print0 | LC_ALL=C sort -z | \
                tar $(TAR_OPTS) -cf $@ --null --no-recursion -T - --numeric-owner)
index 0a404040b048917526aed5739a5097dff276d89f..ae50c5f28462fa2c5a9da625b02b0868d8144eb2 100644 (file)
@@ -555,6 +555,10 @@ ifneq ($(1),host-skeleton)
 $(2)_DEPENDENCIES += host-skeleton
 endif
 
+ifeq ($(filter host-tar host-skeleton,$(1)),)
+$(2)_EXTRACT_DEPENDENCIES += $(BR2_TAR_HOST_DEPENDENCY)
+endif
+
 # Eliminate duplicates in dependencies
 $(2)_FINAL_DEPENDENCIES = $$(sort $$($(2)_DEPENDENCIES))
 $(2)_FINAL_EXTRACT_DEPENDENCIES = $$(sort $$($(2)_EXTRACT_DEPENDENCIES))
index a8a15d9518d25d874b8619678cff7b11fc3baab3..92b6e9eaa55629c4e9189e53ef25b63cbf237f8b 100644 (file)
@@ -47,4 +47,9 @@ endef
 
 HOST_TAR_CONF_OPTS = --without-selinux
 
+# we are built before ccache
+HOST_TAR_CONF_ENV = \
+       CC="$(HOSTCC_NOCCACHE)" \
+       CXX="$(HOSTCXX_NOCCACHE)"
+
 $(eval $(host-autotools-package))
index ad0b32e277338ada2505235a25a0c0a0b00e1f02..07d02fd1b128a001718776c5f6dcc0946b098b16 100644 (file)
@@ -1,6 +1,6 @@
 TAR ?= tar
 
 ifeq (,$(call suitable-host-package,tar,$(TAR)))
-DEPENDENCIES_HOST_PREREQ += host-tar
 TAR = $(HOST_DIR)/bin/tar
+BR2_TAR_HOST_DEPENDENCY = host-tar
 endif