package/lcdproc: add libpng optional dependency
authorRomain Naour <romain.naour@gmail.com>
Mon, 5 Jun 2017 16:16:58 +0000 (18:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 8 Jun 2017 20:05:33 +0000 (22:05 +0200)
Fixes:
http://autobuild.buildroot.net/results/b68/b68f54404a7d412d639ebb6d052412eea6ee3bf1

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lcdproc/lcdproc.mk

index d86eb33f45cbbac3eff3c1d846e1cd5b5f6dd228..c6476eb74555882aade72f18f3b7ff016bceb7c1 100644 (file)
@@ -18,4 +18,11 @@ endif
 
 LCDPROC_DEPENDENCIES = freetype ncurses zlib
 
+ifeq ($(BR2_PACKAGE_LIBPNG),y)
+LCDPROC_DEPENDENCIES += libpng
+LCDPROC_CONF_OPTS += --enable-libpng
+else
+LCDPROC_CONF_OPTS += --disable-libpng
+endif
+
 $(eval $(autotools-package))