opencv: always enable opencv_core module when opencv is enabled
authorSamuel Martin <s.martin49@gmail.com>
Sat, 15 Feb 2014 22:13:23 +0000 (23:13 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 16 Feb 2014 08:17:57 +0000 (09:17 +0100)
It does not make much sense enabling opencv without its core module.

This configuration leads to build nothing (since all modules depend on
the core one), but install the configuration files (*.pc and *.cmake)
anyway.

This absurd situation may break the build-system of other packages
that would correctly find the *.pc (but does not check for the modules
they actually use), but would not build because of missing headers and
libraries.

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/opencv/Config.in
package/opencv/opencv.mk

index ccde5cb349c597489fb8348b8095090623d43075..217243d568d96253b9a7b96024b099c08e0caf2c 100644 (file)
@@ -26,12 +26,6 @@ config BR2_PACKAGE_OPENCV_LIB_CONTRIB
        help
          Include opencv_contrib module into the OpenCV build.
 
-config BR2_PACKAGE_OPENCV_LIB_CORE
-       bool "core"
-       default y
-       help
-         Include opencv_core module into the OpenCV build.
-
 config BR2_PACKAGE_OPENCV_LIB_FEATURES2D
        bool "features2d"
        default y
index 732bc0cc559193ea69cebadde063f75f5f8b6f0a..42f9b0a51ff925399dfee79428ffaf3b7288402e 100644 (file)
@@ -34,7 +34,7 @@ OPENCV_CONF_OPT += \
        -DBUILD_opencv_androidcamera=OFF                                        \
        -DBUILD_opencv_calib3d=$(if $(BR2_PACKAGE_OPENCV_LIB_CALIB3D),ON,OFF)   \
        -DBUILD_opencv_contrib=$(if $(BR2_PACKAGE_OPENCV_LIB_CONTRIB),ON,OFF)   \
-       -DBUILD_opencv_core=$(if $(BR2_PACKAGE_OPENCV_LIB_CORE),ON,OFF)         \
+       -DBUILD_opencv_core=ON                                                  \
        -DBUILD_opencv_features2d=$(if $(BR2_PACKAGE_OPENCV_LIB_FEATURES2D),ON,OFF) \
        -DBUILD_opencv_flann=$(if $(BR2_PACKAGE_OPENCV_LIB_FLANN),ON,OFF)       \
        -DBUILD_opencv_gpu=$(if $(BR2_PACKAGE_OPENCV_LIB_GPU),ON,OFF)           \