package/linux-fusion: require kernel modules from Kconfig
authorYann E. MORIN <yann.morin.1998@free.fr>
Thu, 10 Dec 2015 18:53:14 +0000 (19:53 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 29 Dec 2015 22:51:22 +0000 (23:51 +0100)
And reorder 'depends' after 'bool'.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/linux-fusion/Config.in
package/linux-fusion/linux-fusion.mk

index cdc1dd2d678e1f6439169481327a84355c89f398..ed8bd6ad4897759e9411447121f264f6da3a743a 100644 (file)
@@ -2,8 +2,9 @@ comment "linux-fusion needs a Linux kernel to be built"
        depends on !BR2_LINUX_KERNEL
 
 config BR2_PACKAGE_LINUX_FUSION
-       depends on BR2_LINUX_KERNEL
        bool "linux-fusion communication layer for DirectFB multi"
+       depends on BR2_LINUX_KERNEL
+       select BR2_LINUX_NEEDS_MODULES # not using kernel-module infra
        help
          DirectFB Communication Layer allowing multiple DirectFB
          applications to run concurrently
index ba4bb31448bd83340eb50bdeb9fb8da98660c7fa..35ed28e710fe06be932bbc488f988fba7bed78a2 100644 (file)
@@ -12,12 +12,6 @@ LINUX_FUSION_DEPENDENCIES = linux
 LINUX_FUSION_LICENSE = GPLv2+
 LINUX_FUSION_LICENSE_FILES = debian/copyright
 
-# We're building a kernel module without using the kernel-module infra,
-# so we need to tell we want module support in the kernel
-ifeq ($(BR2_PACKAGE_LINUX_FUSION),y)
-LINUX_NEEDS_MODULES = y
-endif
-
 LINUX_FUSION_ETC_DIR = $(TARGET_DIR)/etc/udev/rules.d
 
 LINUX_FUSION_MAKE_OPTS = \