ccache: replace BUILDROOT_CACHE_DIR with BR_CACHE_DIR.
authorArnout Vandecappelle <arnout@mind.be>
Tue, 4 Feb 2014 15:18:50 +0000 (16:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 5 Feb 2014 11:07:19 +0000 (12:07 +0100)
To make the naming consistent (qstripped variant of a config option
should be named BR_XXX).

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Makefile
package/ccache/ccache.mk

index d05c5844a9db455818157d0327c8c0e4c1c84bad..fceb2e873c5721fe549e4f95082a629c482f0267 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -316,8 +316,8 @@ TARGET_DIR_WARNING_FILE=$(TARGET_DIR)/THIS_IS_NOT_YOUR_ROOT_FILESYSTEM
 
 ifeq ($(BR2_CCACHE),y)
 CCACHE:=$(HOST_DIR)/usr/bin/ccache
-BUILDROOT_CACHE_DIR = $(call qstrip,$(BR2_CCACHE_DIR))
-export BUILDROOT_CACHE_DIR
+BR_CACHE_DIR = $(call qstrip,$(BR2_CCACHE_DIR))
+export BR_CACHE_DIR
 HOSTCC  := $(CCACHE) $(HOSTCC)
 HOSTCXX := $(CCACHE) $(HOSTCXX)
 endif
index 82a53f34c9e2207fefe9033195e1e73f519253a2..40485d147fc6c5db453a24aafab9ef8e23526de6 100644 (file)
@@ -22,16 +22,16 @@ CCACHE_LICENSE_FILES = LICENSE.txt GPL-3.0.txt
 HOST_CCACHE_CONF_OPT += ccache_cv_zlib_1_2_3=no
 
 # Patch host-ccache as follows:
-#  - Use BUILDROOT_CACHE_DIR instead of CCACHE_DIR, because CCACHE_DIR
+#  - Use BR_CACHE_DIR instead of CCACHE_DIR, because CCACHE_DIR
 #    is already used by autotargets for the ccache package.
-#    BUILDROOT_CACHE_DIR is exported by Makefile based on config option
+#    BR_CACHE_DIR is exported by Makefile based on config option
 #    BR2_CCACHE_DIR.
 #  - ccache shouldn't use the compiler binary mtime to detect a change in
 #    the compiler, because in the context of Buildroot, that completely
 #    defeats the purpose of ccache. Of course, that leaves the user
 #    responsible for purging its cache when the compiler changes.
 define HOST_CCACHE_PATCH_CONFIGURATION
-       sed -i 's,getenv("CCACHE_DIR"),getenv("BUILDROOT_CACHE_DIR"),' $(@D)/ccache.c
+       sed -i 's,getenv("CCACHE_DIR"),getenv("BR_CACHE_DIR"),' $(@D)/ccache.c
        sed -i 's,getenv("CCACHE_COMPILERCHECK"),"none",' $(@D)/ccache.c
 endef