autoconf: remove deprecated target package
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Wed, 5 Feb 2014 13:50:54 +0000 (14:50 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 8 Feb 2014 22:26:42 +0000 (23:26 +0100)
The autoconf support on target has been deprecated for more than four
buildroot releases and thus can be removed. This doesn't change anything
about the host autoconf support.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/Config.in
package/autoconf/Config.in [deleted file]
package/autoconf/autoconf.mk

index 09e12878da16c1f574c06a6bf8550c5d8890fb0a..ef81da3b13c9edba7705f54742c65c77fcc8c97a 100644 (file)
@@ -119,6 +119,14 @@ config BR2_sh3eb
          Due to an inexistent user base and generally poor Linux
          support, the support for the SH3eb architecture was removed.
 
+config BR2_PACKAGE_AUTOCONF
+       bool "autoconf target package has been removed"
+       select BR2_LEGACY
+       help
+         The 'autoconf' target package has been removed since it has been
+         deprecated for more than four buildroot releases.
+         Note: the host autoconf still exists.
+
 config BR2_PACKAGE_XSTROKE
        bool "xstroke has been removed"
        select BR2_LEGACY
index 5c558d5713d6e9dfe898954b99954148f9e5028e..d3896e4bdb18c6b230910611f29d754936299955 100644 (file)
@@ -81,7 +81,6 @@ source "package/whetstone/Config.in"
 endmenu
 
 menu "Development tools"
-source "package/autoconf/Config.in"
 source "package/automake/Config.in"
 source "package/binutils/Config.in"
 source "package/bison/Config.in"
diff --git a/package/autoconf/Config.in b/package/autoconf/Config.in
deleted file mode 100644 (file)
index 27f24e4..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-config BR2_PACKAGE_AUTOCONF
-       bool "autoconf"
-       # We no longer support a toolchain on the target
-       depends on BR2_DEPRECATED_SINCE_2012_11
-       select BR2_PACKAGE_PERL
-       help
-         Extensible program for developing configure scripts.  These
-         scripts handle all the mundane system/feature detection.
-
-         http://www.gnu.org/software/autoconf/
index e70aa391eb032f0d1e992c1f2d4fb5acea073a9c..027f7acbc3f96225a987104af7f14f56251f6703 100644 (file)
@@ -11,17 +11,11 @@ AUTOCONF_SITE = $(BR2_GNU_MIRROR)/autoconf
 AUTOCONF_LICENSE = GPLv3+ with exceptions
 AUTOCONF_LICENSE_FILES = COPYINGv3 COPYING.EXCEPTION
 
-AUTOCONF_CONF_ENV = EMACS="no" ac_cv_path_M4=$(HOST_DIR)/usr/bin/m4 \
-                   ac_cv_prog_gnu_m4_gnu=no
-
-AUTOCONF_DEPENDENCIES = host-m4 perl
-
 HOST_AUTOCONF_CONF_ENV = EMACS="no" ac_cv_path_M4=$(HOST_DIR)/usr/bin/m4 \
                        ac_cv_prog_gnu_m4_gnu=no
 
 HOST_AUTOCONF_DEPENDENCIES = host-m4 host-libtool
 
-$(eval $(autotools-package))
 $(eval $(host-autotools-package))
 
 # variables used by other packages