package/links: add optional support for xz
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 10 Feb 2016 20:58:42 +0000 (21:58 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 16 Feb 2016 22:10:08 +0000 (23:10 +0100)
When xz was compiled before, links will use it as optional dependency:

$ output/host/usr/bin/i586-buildroot-linux-uclibc-readelf -a output/target/usr/bin/links | grep NEEDED
 0x00000001 (NEEDED)                     Shared library: [liblzma.so.5]
 0x00000001 (NEEDED)                     Shared library: [libbz2.so.1.0]
 0x00000001 (NEEDED)                     Shared library: [libz.so.1]
 0x00000001 (NEEDED)                     Shared library: [libevent-2.0.so.5]
 0x00000001 (NEEDED)                     Shared library: [libc.so.1]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/links/links.mk

index b948de4d20241d40d740fdb39da5fa6a468202c7..4d2cb2e099d2056fec6ab336f9c241a2e2c5a6ac 100644 (file)
@@ -47,6 +47,10 @@ ifeq ($(BR2_PACKAGE_OPENSSL),y)
 LINKS_DEPENDENCIES += openssl
 endif
 
+ifeq ($(BR2_PACKAGE_XZ),y)
+LINKS_DEPENDENCIES += xz
+endif
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 LINKS_DEPENDENCIES += zlib
 endif