make source-check without permanently changing WGET command
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Fri, 20 Jul 2007 07:34:28 +0000 (07:34 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Fri, 20 Jul 2007 07:34:28 +0000 (07:34 -0000)
Makefile
package/Makefile.in

index a4d09eb89f147ffeb1923db545a5fe302680e363..53a647111db6c5ba9fad4fcb6cae2ed603c86f8f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -252,12 +252,8 @@ $(TARGET_DIR)/etc/hostname:        $(TARGET_DIR) .config
 
 source: $(TARGETS_SOURCE) $(HOST_SOURCE)
 
-.config.check: dependencies
-       $(SED) '/BR2_WGET/s/\"$$/ --spider\"/g' .config
-       touch $@
-
-_source-check: .config.check
-       $(MAKE) source
+_source-check: 
+       $(MAKE) SPIDER=--spider source
 
 #############################################################
 #
index 29c505835fa8341b86c84bc757aa265feb940f04..78731e24f467c27a701faa70f94d055dff16a626 100644 (file)
@@ -12,7 +12,7 @@ MAKE:=$(HOSTMAKE) -j$(BR2_JLEVEL)
 # Strip off the annoying quoting
 ARCH:=$(strip $(subst ",, $(BR2_ARCH)))
 #"))
-WGET:=$(strip $(subst ",, $(BR2_WGET)))
+WGET:=$(strip $(subst ",, $(BR2_WGET))) $(SPIDER)
 #"))
 SVN:=$(strip $(subst ",, $(BR2_SVN)))
 #"))