urg: handle config scripts properly
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 17 Mar 2013 22:36:18 +0000 (22:36 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 18 Mar 2013 08:46:02 +0000 (09:46 +0100)
urg installs two <foo>-config scripts, so the ones installed in
$(STAGING_DIR) should be fixed up, and the ones installed in
$(TARGET_DIR) should be removed. Use the <pkg>_CONFIG_SCRIPTS
infrastructure to do this.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/urg/urg.mk

index b544ece8eabadb9562d3b806362453a02e693f0c..99f63a9cd01082edd88bc3226c4d874c915793a0 100644 (file)
@@ -17,6 +17,8 @@ URG_DEPENDENCIES = sdl sdl_net
 URG_CONF_OPT = --with-sdl-prefix=$(STAGING_DIR)/usr \
                --with-sdl-exec-prefix=$(STAGING_DIR)/usr
 
+URG_CONFIG_SCRIPTS = c_urg-config urg-config
+
 define URG_EXTRACT_CMDS
        $(RM) -rf $(URG_DIR)
        unzip -q -d $(BUILD_DIR)/ $(DL_DIR)/$(URG_SOURCE)