boot/barebox: needs host-{flex,bison}
authorMarcin Niestroj <m.niestroj@grinn-global.com>
Tue, 2 Jul 2019 20:13:41 +0000 (22:13 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 3 Jul 2019 21:32:50 +0000 (23:32 +0200)
Barebox starting from 2019.02 no longer ships flex/bison generated
parser. Add conditional kconfig dependencies, same as we did for kernel
and uboot.

Signed-off-by: Marcin Niestroj <m.niestroj@grinn-global.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
boot/barebox/barebox.mk

index 9e8a9f67b57ed93be86c5621e8107ca1ff48a473..52178d89c8462c904e66cb46d17fbf16b4d4676f 100644 (file)
@@ -76,6 +76,10 @@ $(1)_KCONFIG_FRAGMENT_FILES = $$(call qstrip,$$(BR2_TARGET_$(1)_CONFIG_FRAGMENT_
 $(1)_KCONFIG_EDITORS = menuconfig xconfig gconfig nconfig
 $(1)_KCONFIG_OPTS = $$($(1)_MAKE_FLAGS)
 
+$(1)_KCONFIG_DEPENDENCIES = \
+       $(BR2_BISON_HOST_DEPENDENCY) \
+       $(BR2_FLEX_HOST_DEPENDENCY)
+
 ifeq ($$(BR2_TARGET_$(1)_BAREBOXENV),y)
 define $(1)_BUILD_BAREBOXENV_CMDS
        $$(TARGET_CC) $$(TARGET_CFLAGS) $$(TARGET_LDFLAGS) -o $$(@D)/bareboxenv \