samba: fix dependencies
authorSven Neumann <s.neumann@raumfeld.com>
Mon, 21 Sep 2009 16:21:53 +0000 (18:21 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 21 Sep 2009 21:28:23 +0000 (23:28 +0200)
The samba configure scripts detects the presence of fam and avahi
headers in order to decide whether support for fam and/or avahi should
be built into samba. This patch adds the missing dependencies so that
fam and/or avahi are built before samba if they are selected in buildroot.

Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/samba/samba.mk

index c4ecebf2d665e059cb277b89e7b22616fc63537c..1cead4083a246ddcd7dcec6468f810c1834f2dd5 100644 (file)
@@ -11,6 +11,8 @@ SAMBA_CAT:=$(ZCAT)
 SAMBA_BINARY:=bin/smbd
 SAMBA_TARGET_BINARY:=usr/sbin/smbd
 
+SAMBA_DEPENDENCIES=libiconv
+
 ifeq ($(BR2_PACKAGE_SAMBA_LIBSMBCLIENT),y)
 SAMBA_LIBSMBCLIENT := libsmbclient
 SAMBA_CONF_OPTIONS := --enable-libsmbclient
@@ -19,6 +21,21 @@ SAMBA_LIBSMBCLIENT :=
 SAMBA_CONF_OPTIONS := --disable-libsmbclient
 endif
 
+ifeq ($(BR2_PACKAGE_AVAHI),y)
+SAMBA_CONF_OPTIONS := --enable-avahi
+SAMBA_DEPENDENCIES += avahi
+else
+SAMBA_CONF_OPTIONS := --disable-avahi
+endif
+
+ifeq ($(BR2_PACKAGE_GAMIN),y)
+SAMBA_CONF_OPTIONS := --enable-fam
+SAMBA_DEPENDENCIES += gamin
+else
+SAMBA_CONF_OPTIONS := --disable-fam
+endif
+
+
 $(DL_DIR)/$(SAMBA_SOURCE):
        $(call DOWNLOAD,$(SAMBA_SITE),$(SAMBA_SOURCE))
 
@@ -147,7 +164,7 @@ libsmbclient: $(SAMBA_DIR)/bin/libsmbclient.so
                DESTDIR="$(STAGING_DIR)" \
                -C $(SAMBA_DIR) installlibs
 
-samba: libiconv $(TARGET_DIR)/$(SAMBA_TARGET_BINARY) $(SAMBA_LIBSMBCLIENT)
+samba: $(SAMBA_DEPENDENCIES) $(TARGET_DIR)/$(SAMBA_TARGET_BINARY) $(SAMBA_LIBSMBCLIENT)
 
 samba-source: $(DL_DIR)/$(SAMBA_SOURCE)