pps-tools: new package
authorBryan Brinsko <bryan.brinsko@rockwellcollins.com>
Thu, 16 Oct 2014 17:30:53 +0000 (12:30 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 19 Oct 2014 15:22:37 +0000 (17:22 +0200)
Added pps-tools package to add support to the ntpd for a
pps source (requires timepps.h from pps-tools as part of ntpd
build).

[Thomas:
  - Use $(TARGET_MAKE_ENV) at install time.
  - Alphabetic ordering in package/Config.in, noticed by Jerzy
    Grzegorek.]

Signed-off-by: Bryan Brinsko <bryan.brinsko@rockwellcollins.com>
Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/pps-tools/Config.in [new file with mode: 0644]
package/pps-tools/pps-tools.mk [new file with mode: 0644]

index 7b18715e848b2090bbd93d72fa4f8b47a11798eb..89b46dce9f805d0166ea90a934530b48133510d3 100644 (file)
@@ -353,6 +353,7 @@ endif
        source "package/pciutils/Config.in"
        source "package/picocom/Config.in"
        source "package/pifmrds/Config.in"
+       source "package/pps-tools/Config.in"
        source "package/read-edid/Config.in"
        source "package/rng-tools/Config.in"
        source "package/rpi-userland/Config.in"
diff --git a/package/pps-tools/Config.in b/package/pps-tools/Config.in
new file mode 100644 (file)
index 0000000..83308f4
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PPS_TOOLS
+       bool "pps-tools"
+       help
+         Pulse per second tools. Provides timepps.h and other PPS utilities.
+
+         https://github.com/ago/pps-tools/
diff --git a/package/pps-tools/pps-tools.mk b/package/pps-tools/pps-tools.mk
new file mode 100644 (file)
index 0000000..7876403
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# pps-tools
+#
+################################################################################
+
+PPS_TOOLS_VERSION = 0deb9c7e135e9380a6d09e9d2e938a146bb698c8
+PPS_TOOLS_SITE = $(call github,ago,pps-tools,$(PPS_TOOLS_VERSION))
+PPS_TOOLS_INSTALL_STAGING = YES
+PPS_TOOLS_LICENSE = GPLv2+
+PPS_TOOLS_LICENSE_FILES = COPYING
+
+define PPS_TOOLS_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) all
+endef
+
+define PPS_TOOLS_INSTALL_STAGING_CMDS
+       mkdir -p $(STAGING_DIR)/usr/include/sys $(STAGING_DIR)/usr/bin
+       $(TARGET_MAKE_ENV) $(MAKE) DESTDIR=$(STAGING_DIR) -C $(@D) install
+endef
+
+define PPS_TOOLS_INSTALL_TARGET_CMDS
+       mkdir -p $(TARGET_DIR)/usr/include/sys $(TARGET_DIR)/usr/bin
+       $(TARGET_MAKE_ENV) $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) install
+endef
+
+$(eval $(generic-package))