package/rpm: explicit audit option
authorJames Knight <james.d.knight@live.com>
Sat, 4 Sep 2021 20:40:24 +0000 (16:40 -0400)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 11 Sep 2021 20:33:37 +0000 (22:33 +0200)
Support for Linux audit has existed [1] since a v4.15 release; manage
the configuration option explicitly.

[1]: https://github.com/rpm-software-management/rpm/commit/ad16a04b6e41612cdef6ab8755ad31c8b880a9fd

Signed-off-by: James Knight <james.d.knight@live.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/rpm/rpm.mk

index 816deceff7e3784cb7bf04ded87a834d16a5aa85..e9d2adf690cc0626e209ec7d1acad9c0ecf0a95c 100644 (file)
@@ -38,6 +38,13 @@ else
 RPM_CONF_OPTS += --without-acl
 endif
 
+ifeq ($(BR2_PACKAGE_AUDIT),y)
+RPM_DEPENDENCIES += audit
+RPM_CONF_OPTS += --with-audit
+else
+RPM_CONF_OPTS += --without-audit
+endif
+
 ifeq ($(BR2_PACKAGE_DBUS),y)
 RPM_DEPENDENCIES += dbus
 RPM_CONF_OPTS += --enable-plugins