package/qt5/qt5remoteobjects: new package
authorSven Fischer <sven@leiderfischer.de>
Mon, 9 Mar 2020 12:00:24 +0000 (13:00 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 6 Oct 2020 21:09:35 +0000 (23:09 +0200)
Qt 5.12 added a library for IPC, so let's have a package for it. The
dependency on qtdeclarative is optional.

Signed-off-by: Sven Fischer <sven@leiderfischer.de>
Reviewed-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/qt5/Config.in
package/qt5/qt5remoteobjects/Config.in [new file with mode: 0644]
package/qt5/qt5remoteobjects/qt5remoteobjects.hash [new file with mode: 0644]
package/qt5/qt5remoteobjects/qt5remoteobjects.mk [new file with mode: 0644]

index 407b2b2afc51b851534fd2f35bddcc9973c01a61..354b85605f84d8148bfd4b25be66c48e96d9ff93 100644 (file)
@@ -2538,6 +2538,9 @@ F:        configs/rock_pi_n10_defconfig
 F:     configs/rockpro64_defconfig
 F:     package/arm-gnu-a-toolchain/
 
+F:     Sven Fischer <sven@leiderfischer.de>
+N:     package/qt5/qt5remoteobjects/
+
 N:     Sven Haardiek <sven.haardiek@iotec-gmbh.de>
 F:     package/lcdproc/
 F:     package/python-influxdb/
index e897c7cbcb9e9552f50144044f5d3319f23ec5e8..c31f8267f329bd7b4565f806582b24c9aadab706 100644 (file)
@@ -50,6 +50,7 @@ source "package/qt5/qt5multimedia/Config.in"
 source "package/qt5/qt5quickcontrols/Config.in"
 source "package/qt5/qt5quickcontrols2/Config.in"
 source "package/qt5/qt5quicktimeline/Config.in"
+source "package/qt5/qt5remoteobjects/Config.in"
 source "package/qt5/qt5script/Config.in"
 source "package/qt5/qt5scxml/Config.in"
 source "package/qt5/qt5sensors/Config.in"
diff --git a/package/qt5/qt5remoteobjects/Config.in b/package/qt5/qt5remoteobjects/Config.in
new file mode 100644 (file)
index 0000000..9d4a40a
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_QT5REMOTEOBJECTS
+       bool "qt5remoteobjects"
+       select BR2_PACKAGE_QT5BASE
+       select BR2_PACKAGE_QT5BASE_NETWORK
+       help
+         Qt is a cross-platform application and UI framework for
+         developers using C++.
+
+         Qt Remote Objects (QtRO) is an Inter-Process
+         Communication (IPC) module developed for Qt. This
+         module extends Qt's existing functionalities to enable
+         information exchange between processes or computers,
+         easily.
+
+         https://doc.qt.io/qt-5/qtremoteobjects-index.html
diff --git a/package/qt5/qt5remoteobjects/qt5remoteobjects.hash b/package/qt5/qt5remoteobjects/qt5remoteobjects.hash
new file mode 100644 (file)
index 0000000..6575a47
--- /dev/null
@@ -0,0 +1,8 @@
+# Hash from: https://download.qt.io/official_releases/qt/5.15/5.15.1/submodules/qtremoteobjects-everywhere-src-5.15.1.tar.xz.sha256
+sha256 71b58fdac717645fa6f8b6ecb79b86841c540838877d100fabe2381175c4154e  qtremoteobjects-everywhere-src-5.15.1.tar.xz
+
+# Hashes for license files:
+sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 LICENSE.GPL2
+sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 LICENSE.GPL3
+sha256 0dbe024961f6ab5c52689cbd036c977975d0d0f6a67ff97762d96cb819dd5652 LICENSE.GPL3-EXCEPT
+sha256 da7eabb7bafdf7d3ae5e9f223aa5bdc1eece45ac569dc21b3b037520b4464768 LICENSE.LGPL3
diff --git a/package/qt5/qt5remoteobjects/qt5remoteobjects.mk b/package/qt5/qt5remoteobjects/qt5remoteobjects.mk
new file mode 100644 (file)
index 0000000..4b03a09
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# qt5remoteobjects
+#
+################################################################################
+
+QT5REMOTEOBJECTS_VERSION = $(QT5_VERSION)
+QT5REMOTEOBJECTS_SITE = $(QT5_SITE)
+QT5REMOTEOBJECTS_SOURCE = qtremoteobjects-$(QT5_SOURCE_TARBALL_PREFIX)-$(QT5REMOTEOBJECTS_VERSION).tar.xz
+QT5REMOTEOBJECTS_DEPENDENCIES = qt5base
+QT5REMOTEOBJECTS_INSTALL_STAGING = YES
+QT5REMOTEOBJECTS_LICENSE = GPL-2.0+ or LGPL-3.0, GPL-3.0 with exception (tools), GFDL-1.3 (docs)
+QT5REMOTEOBJECTS_LICENSE_FILES = LICENSE.GPL2 LICENSE.GPL3 LICENSE.GPL3-EXCEPT LICENSE.LGPL3 LICENSE.FDL
+
+ifeq ($(BR2_PACKAGE_QT5DECLARATIVE),y)
+QT5REMOTEOBJECTS_DEPENDENCIES += qt5declarative
+endif
+
+$(eval $(qmake-package))