libxml2: do not apply libtool patch when compiling for host
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 20 Feb 2010 17:11:37 +0000 (18:11 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 20 Feb 2010 18:31:04 +0000 (19:31 +0100)
The libtool patch is not applied when building for the target because
it does not apply, so do not attempt to apply it when building for the
host. This fixes libxml2 build for the host.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libxml2/libxml2.mk

index e598d36cbaa0f325a41e5f28c2ecadc14d42b06c..31fdabfa1ad84cbef2aba91e57e7867a51a08814 100644 (file)
@@ -28,6 +28,8 @@ HOST_LIBXML2_CONF_OPT = \
                --enable-shared --without-debugging --without-python \
                --without-threads
 
+HOST_LIBXML2_LIBTOOL_PATCH = NO
+
 $(eval $(call AUTOTARGETS,package,libxml2))
 $(eval $(call AUTOTARGETS,package,libxml2,host))