docker-containerd: remove symlink to $(RUNC_SRCDIR)
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 31 Mar 2018 13:27:29 +0000 (15:27 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 31 Mar 2018 17:57:31 +0000 (19:57 +0200)
The DOCKER_CONTAINERD_CONFIGURE_CMDS creates a symlink to runc's
source directory, but it does not build depend on runc, which means
that the runc package may not have been extracted/built before
docker-containerd.

Therefore, when doing a build with "make docker-containerd", this
symbolic link is broken, but it doesn't prevent docker-containerd from
building.

Therefore, this symlink is not necessary and can be dropped.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/docker-containerd/docker-containerd.mk

index ffbadb0c3f9cdb2de89b4516d900f8cbb6733d79..8f0822b77fae6dac2858df5decfab62827500d18 100644 (file)
@@ -27,8 +27,6 @@ endif
 define DOCKER_CONTAINERD_CONFIGURE_CMDS
        mkdir -p $(DOCKER_CONTAINERD_GOPATH)/src/github.com/docker
        ln -s $(@D) $(DOCKER_CONTAINERD_GOPATH)/src/github.com/docker/containerd
-       mkdir -p $(DOCKER_CONTAINERD_GOPATH)/src/github.com/opencontainers
-       ln -s $(RUNC_SRCDIR) $(DOCKER_CONTAINERD_GOPATH)/src/github.com/opencontainers/runc
 endef
 
 define DOCKER_CONTAINERD_BUILD_CMDS