cloop: ensure target directory exist before copying into
authorLionel Landwerlin <llandwerlin@gmail.com>
Thu, 9 Dec 2010 09:55:02 +0000 (10:55 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 12 Dec 2010 23:15:43 +0000 (00:15 +0100)
Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/cloop/cloop.mk

index 0ed9ff0ba7b298cdbdb18b8930151074c21334f4..4c160986c9ce29d2cd86a54cea99776076a4f0c8 100644 (file)
@@ -10,9 +10,10 @@ define HOST_CLOOP_BUILD_CMDS
 endef
 
 define HOST_CLOOP_INSTALL_CMDS
- install -m 755 $(@D)/create_compressed_fs $(HOST_DIR)/usr/bin
- install -m 755 $(@D)/extract_compressed_fs $(HOST_DIR)/usr/bin
+       $(INSTALL) -m 0755 -d $(HOST_DIR)/usr/bin
+       $(INSTALL) -m 755 $(@D)/create_compressed_fs $(HOST_DIR)/usr/bin
+       $(INSTALL) -m 755 $(@D)/extract_compressed_fs $(HOST_DIR)/usr/bin
 endef
 
 $(eval $(call GENTARGETS,package,cloop))
-$(eval $(call GENTARGETS,package,cloop,host))
\ No newline at end of file
+$(eval $(call GENTARGETS,package,cloop,host))