mksquashfs is always rebuilt before generating rootfs image. The attached
authorEric Andersen <andersen@codepoet.org>
Fri, 24 Jun 2005 03:14:20 +0000 (03:14 -0000)
committerEric Andersen <andersen@codepoet.org>
Fri, 24 Jun 2005 03:14:20 +0000 (03:14 -0000)
patch avoids this issue, by creating a .unpacked file in the squashfs directory
after the source tarball is unpacked, and making the mksquashfs target depend
on the .unpacked file.

http://bugs.busybox.net/view.php?id=234

target/squashfs/squashfsroot.mk

index d969efed03b3eb737288ee71f50c0b3fddbb3b0a..300e07091d56ebb579dc3965c5a24948eebb3bcf 100644 (file)
@@ -10,11 +10,12 @@ SQUASHFS_SITE=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/sq
 $(DL_DIR)/$(SQUASHFS_SOURCE):
         $(WGET) -P $(DL_DIR) $(SQUASHFS_SITE)/$(SQUASHFS_SOURCE)
 
-$(SQUASHFS_DIR): $(DL_DIR)/$(SQUASHFS_SOURCE) #$(SQUASHFS_PATCH)
+$(SQUASHFS_DIR)/.unpacked: $(DL_DIR)/$(SQUASHFS_SOURCE) #$(SQUASHFS_PATCH)
        zcat $(DL_DIR)/$(SQUASHFS_SOURCE) | tar -C $(BUILD_DIR) -xvf -
        toolchain/patch-kernel.sh $(SQUASHFS_DIR) target/squashfs/ squashfs.patch
+       touch $(SQUASHFS_DIR)/.unpacked
 
-$(SQUASHFS_DIR)/squashfs-tools/mksquashfs: $(SQUASHFS_DIR)
+$(SQUASHFS_DIR)/squashfs-tools/mksquashfs: $(SQUASHFS_DIR)/.unpacked
        $(MAKE) -C $(SQUASHFS_DIR)/squashfs-tools;
 
 squashfs: $(SQUASHFS_DIR)/squashfs-tools/mksquashfs