- make sure we have a build_$arch dir for -menuconfig even when in a pristine checkout
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 23 Mar 2007 13:26:51 +0000 (13:26 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 23 Mar 2007 13:26:51 +0000 (13:26 -0000)
package/busybox/busybox.mk

index ca7c9444f20ff7412f1c382d3c42ffc1e50091cb..0157e97e347e0c12dc867e23192133238da1e11c 100644 (file)
@@ -109,7 +109,7 @@ endif
 
 busybox: uclibc $(TARGET_DIR)/bin/busybox
 
-busybox-menuconfig: host-sed busybox-source $(BUSYBOX_DIR)/.configured
+busybox-menuconfig: host-sed $(BUILD_DIR) busybox-source $(BUSYBOX_DIR)/.configured
        $(MAKE) __TARGET_ARCH=$(ARCH) -C $(BUSYBOX_DIR) menuconfig
        cp -f $(BUSYBOX_DIR)/.config $(BUSYBOX_CONFIG_FILE)