package/libiio: fix compile without thread support
authorPeter Seiderer <ps.report@gmx.net>
Thu, 16 Sep 2021 17:37:03 +0000 (19:37 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 18 Sep 2021 12:23:01 +0000 (14:23 +0200)
- fix compile without thread support (add configure option
  '-DNO_THREADS=ON' as requested)

Fixes:

  - http://autobuild.buildroot.net/results/2cca5952e7d677cd0d5fa97aa1a7bf3e722df3a2

  CMake Error at CMakeLists.txt:409 (message):
    Unable to find pthread dependency.

    If you want to disable multi-threading support, set NO_THREADS=ON.

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libiio/libiio.mk

index 4ce933a0cd8e04438712540194d652c91af1ccde..f706298c2275bd75c85ea6972f33a813cfc1dc1a 100644 (file)
@@ -17,6 +17,12 @@ LIBIIO_CONF_OPTS = -DENABLE_IPV6=ON \
        -DWITH_TESTS=$(if $(BR2_PACKAGE_LIBIIO_TESTS),ON,OFF) \
        -DWITH_DOC=OFF
 
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
+LIBIIO_CONF_OPTS += -DNO_THREADS=OFF
+else
+LIBIIO_CONF_OPTS += -DNO_THREADS=ON
+endif
+
 ifeq ($(BR2_PACKAGE_LIBIIO_XML_BACKEND),y)
 LIBIIO_DEPENDENCIES += libxml2
 LIBIIO_CONF_OPTS += -DWITH_XML_BACKEND=ON