openssl: fix bug #6770
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 9 Jan 2014 23:20:14 +0000 (20:20 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 10 Jan 2014 14:40:21 +0000 (15:40 +0100)
openssl 1.0.1f Makefile.org doesn't quote $(CC) when passing the
parameter in another invocation of make, hence breaking when the
compiler string contains a space with multiple strings (for example with
ccache).

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/openssl/openssl-003-quote-cc.patch [new file with mode: 0644]

diff --git a/package/openssl/openssl-003-quote-cc.patch b/package/openssl/openssl-003-quote-cc.patch
new file mode 100644 (file)
index 0000000..2c035d9
--- /dev/null
@@ -0,0 +1,21 @@
+From 9aef04d9baa0a4bb5b8db92e9ab93b0a857a7659 Mon Sep 17 00:00:00 2001
+From: Gustavo Zacarias <gustavo@zacarias.com.ar>
+Date: Thu, 9 Jan 2014 20:08:04 -0300
+Subject: [PATCH] Makefile.org: enclose CC parameter passing in quotes
+
+The compiler invocation might contain a space like when using ccache.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura openssl-1.0.1f.orig/Makefile.org openssl-1.0.1f/Makefile.org
+--- openssl-1.0.1f.orig/Makefile.org   2014-01-09 19:57:23.324040960 -0300
++++ openssl-1.0.1f/Makefile.org        2014-01-09 20:11:23.821070726 -0300
+@@ -302,7 +302,7 @@
+                       FIPSLD_CC="$(CC)"; CC=$(FIPSDIR)/bin/fipsld; \
+                       export CC FIPSLD_CC FIPSLD_LIBCRYPTO; \
+               fi; \
+-              $(MAKE) -e SHLIBDIRS=crypto  CC=$${CC:-$(CC)} build-shared; \
++              $(MAKE) -e SHLIBDIRS=crypto  CC="$${CC:-$(CC)}" build-shared; \
+               touch -c fips_premain_dso$(EXE_EXT); \
+       else \
+               echo "There's no support for shared libraries on this platform" >&2; \