vnstat: needs host-pkgconf
authorJörg Krause <joerg.krause@embedded.rocks>
Mon, 11 Apr 2016 19:49:52 +0000 (21:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 13 Apr 2016 19:37:14 +0000 (21:37 +0200)
vnstat uses the PKG_CHECK_MODULES macro and therefore requires pkg-config.

Note that for adding the dependency gd to VNSTAT_DEPENDENCIES the assignment
was changed from '=' to '+='.

Fixes:
http://autobuild.buildroot.net/results/4dd/4ddb0d7d7fe2509ff9c4753d918e0bebd7725c13/

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/vnstat/vnstat.mk

index ba2610abfc8d8b183fd364c0ee95c91632981c99..576f240a28021b8bee486a82d1469fd7b67517ed 100644 (file)
@@ -8,11 +8,12 @@ VNSTAT_VERSION = 1.15
 VNSTAT_SITE = http://humdi.net/vnstat
 VNSTAT_LICENSE = GPLv2
 VNSTAT_LICENSE_FILES = COPYING
+VNSTAT_DEPENDENCIES = host-pkgconf
 # We're patching configure.ac, so we need to autoreconf
 VNSTAT_AUTORECONF = YES
 
 ifeq ($(BR2_PACKAGE_GD)$(BR2_PACKAGE_LIBPNG),yy)
-VNSTAT_DEPENDENCIES = gd
+VNSTAT_DEPENDENCIES += gd
 VNSTAT_CONF_OPTS = --enable-image-output
 else
 VNSTAT_CONF_OPTS = --disable-image-output