package/xenomai: disable obstack support
authorRomain Naour <romain.naour@gmail.com>
Fri, 31 Mar 2017 20:26:04 +0000 (22:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 15 Apr 2017 10:00:09 +0000 (12:00 +0200)
Obstack support in Xenomai is broken when the libc doesn't support
obstack support itself. Make sure we disable obstack support for all
libc since it was removed in uClibc-ng since 1.0.21 release and it's
always disabled with Glibc.

Fixes:
http://autobuild.buildroot.net/results/555/555d9cb9cb59fad6353516bed206e1117974e8cd/build-end.log

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Pawel Sikora <sikor6@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xenomai/xenomai.mk

index bd147a9ec6c2b04866e1dea93339d62969238a7e..4ae045af099b46e96612140d573830fdede8bc37 100644 (file)
@@ -35,6 +35,12 @@ else
 XENOMAI_CONF_OPTS += --disable-smp
 endif
 
+# Obstack support in Xenomai is broken when the libc doesn't support
+# obstack support itself. Make sure we disable obstack support for all
+# libc since it was removed in uClibc-ng since 1.0.21 release and it's
+# always disabled with Glibc.
+XENOMAI_CONF_OPTS += CFLAGS="$(TARGET_CFLAGS) -DELIDE_CODE"
+
 define XENOMAI_REMOVE_DEVFILES
        for i in xeno-config xeno-info wrap-link.sh ; do \
                rm -f $(TARGET_DIR)/usr/bin/$$i ; \