package/jszip: new package
authorJoeri Barbarien <joeri.barbarien@nokia.com>
Tue, 8 Dec 2020 18:05:24 +0000 (19:05 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 2 Jan 2021 10:31:58 +0000 (11:31 +0100)
Signed-off-by: Joeri Barbarien <joeri.barbarien@nokia.com>
Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/jszip/Config.in [new file with mode: 0644]
package/jszip/jszip.hash [new file with mode: 0644]
package/jszip/jszip.mk [new file with mode: 0644]

index f02011cd49d63cc0cd2c312f02be692f8846fa11..6ff5a31a1de064713e83225a4b0e5c125f5cdcbc 100644 (file)
@@ -2515,6 +2515,7 @@ N:        Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
 F:     docs/manual/
 F:     package/cereal/
 F:     package/chartjs/
+F:     package/jszip/
 F:     package/libtelnet/
 F:     package/opkg-utils/
 F:     package/perl-convert-asn1/
index 4690c54a66fad7880ce1a06f59aa69a396c24ae3..9e8f354d1bf732796f0084269f77a3c4745d2b7f 100644 (file)
@@ -1597,6 +1597,7 @@ endmenu
 endif
        source "package/jsmin/Config.in"
        source "package/json-javascript/Config.in"
+       source "package/jszip/Config.in"
        source "package/openlayers/Config.in"
        source "package/spidermonkey/Config.in"
        source "package/vuejs/Config.in"
diff --git a/package/jszip/Config.in b/package/jszip/Config.in
new file mode 100644 (file)
index 0000000..455891a
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_JSZIP
+       bool "jszip"
+       help
+         JSZip is a javascript library for creating, reading and
+         editing .zip files, with a lovely and simple API.
+
+         https://stuk.github.io/jszip
diff --git a/package/jszip/jszip.hash b/package/jszip/jszip.hash
new file mode 100644 (file)
index 0000000..13a2076
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed:
+sha256 e5343decfb781b15c54c0df9ddedd6c8518c800a4667a0a95741c694a4f38d34  jszip-3.2.2.tar.gz
+sha256 14450c78405ad2a2173e25740b56406556779149df9c4c83523a8c63d0686210  LICENSE.markdown
diff --git a/package/jszip/jszip.mk b/package/jszip/jszip.mk
new file mode 100644 (file)
index 0000000..04bd0a7
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# jszip
+#
+################################################################################
+
+JSZIP_VERSION = 3.2.2
+JSZIP_SITE = $(call github,Stuk,jszip,v$(JSZIP_VERSION))
+JSZIP_LICENSE = MIT or GPL-3.0
+JSZIP_LICENSE_FILES = LICENSE.markdown
+
+define JSZIP_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0644 -D $(@D)/dist/jszip.min.js \
+               $(TARGET_DIR)/var/www/jszip/js/jszip.min.js
+endef
+
+$(eval $(generic-package))