linux: don't force IPv6 configuration in kernel
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Dec 2010 18:50:17 +0000 (19:50 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 22 Dec 2010 21:19:30 +0000 (22:19 +0100)
As per the discussion at
http://lists.busybox.net/pipermail/buildroot/2010-December/040030.html,
remove the bits that forced the IPv6 configuration in the kernel
depending on the toolchain ability to support (or not) IPv6. You may
have a toolchain with IPv6 support but still don't want to have IPv6
in your kernel.

The only parameters we adjust in the kernel configuration are:

 * ARM EABI, since we got a lot of bug reports regarding misconfigured
   kernel compared to the ABI used by userspace applications.

 * initramfs, since its contents are generated by Buildroot itself

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
linux/linux.mk

index f2c6fd51286fe3ee373ccf90895ea2b4ced5e02c..f81ff5c1edeacdae8987ae194a3e33c73c662912 100644 (file)
@@ -112,11 +112,6 @@ ifeq ($(BR2_ARM_EABI),y)
 else
        $(call KCONFIG_DISABLE_OPT,CONFIG_AEABI,$(@D)/.config)
 endif
-ifeq ($(BR2_INET_IPV6),y)
-       $(call KCONFIG_ENABLE_OPT,CONFIG_IPV6,$(@D)/.config)
-else
-       $(call KCONFIG_DISABLE_OPT,CONFIG_IPV6,$(@D)/.config)
-endif
 ifeq ($(BR2_TARGET_ROOTFS_INITRAMFS),y)
        # As the kernel gets compiled before root filesystems are
        # built, we create a fake initramfs file list. It'll be