package: Force copy of .la files at the post install hook (readonly files might be...
authorLionel Landwerlin <llandwerlin@gmail.com>
Fri, 30 Apr 2010 00:24:06 +0000 (02:24 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 2 May 2010 07:32:14 +0000 (09:32 +0200)
Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.autotools.in

index 34aab77a27ccc4c952ae8d088bc2c4a89f4ade6d..b7a71035946b51b12c1580e724af7d736e423b53 100644 (file)
@@ -201,7 +201,7 @@ ifndef $(2)_INSTALL_STAGING_CMDS
 define $(2)_INSTALL_STAGING_CMDS
        $$($$(PKG)_MAKE_ENV) $$($$(PKG)_MAKE) $$($$(PKG)_INSTALL_STAGING_OPT) -C $$($$(PKG)_SRCDIR)
        for i in $$$$(find $(STAGING_DIR)/usr/lib* -name "*.la"); do \
-               cp $$$$i $$$$i~; \
+               cp -f $$$$i $$$$i~; \
                $$(SED) "s:\(['= ]\)/usr:\\1$(STAGING_DIR)/usr:g" $$$$i; \
        done
 endef