package/git: bump version to 2.15.0
authorBernd Kuhls <bernd.kuhls@t-online.de>
Tue, 31 Oct 2017 08:16:24 +0000 (09:16 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 31 Oct 2017 19:09:20 +0000 (20:09 +0100)
To avoid the build error

grep.c:(.text+0xa02): undefined reference to `pcre_jit_exec'

we need to add NO_LIBPCRE1_JIT=1 according to
https://www.spinics.net/lists/git/msg314515.html

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/git/git.hash
package/git/git.mk

index d65296f17a4a9711fc4d16461793cb0e282d6631..79a386eb7222bf232e884597d2a2ab7fd4fd943c 100644 (file)
@@ -1,4 +1,4 @@
 # From: https://www.kernel.org/pub/software/scm/git/sha256sums.asc
-sha256 bce97e403bea34f50378e90ade10c12666b2382cc247551b63dc5604e03b2523  git-2.13.6.tar.xz
+sha256 107116489f10b758b51af1c5dbdb9a274917b0fb67dc8eaefcdabc7bc3eb3e6a  git-2.15.0.tar.xz
 sha256 5b2198d1645f767585e8a88ac0499b04472164c0d2da22e75ecf97ef443ab32e  COPYING
 sha256 1922f45d2c49e390032c9c0ba6d7cac904087f7cec51af30c2b2ad022ce0e76a  LGPL-2.1
index 9f13f0f6aa8bf3f6185da3b01b5cd671e84c91da..181e7421e220833162346452a895891e215fa8c4 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-GIT_VERSION = 2.13.6
+GIT_VERSION = 2.15.0
 GIT_SOURCE = git-$(GIT_VERSION).tar.xz
 GIT_SITE = $(BR2_KERNEL_MIRROR)/software/scm/git
 GIT_LICENSE = GPL-2.0, LGPL-2.1+
@@ -22,6 +22,7 @@ endif
 ifeq ($(BR2_PACKAGE_PCRE),y)
 GIT_DEPENDENCIES += pcre
 GIT_CONF_OPTS += --with-libpcre
+GIT_MAKE_OPTS += NO_LIBPCRE1_JIT=1
 else
 GIT_CONF_OPTS += --without-libpcre
 endif
@@ -58,7 +59,7 @@ GIT_CONF_OPTS += --without-tcltk
 endif
 
 ifeq ($(BR2_SYSTEM_ENABLE_NLS),)
-GIT_MAKE_OPTS = NO_GETTEXT=1
+GIT_MAKE_OPTS += NO_GETTEXT=1
 endif
 
 GIT_INSTALL_TARGET_OPTS = $(GIT_MAKE_OPTS) DESTDIR=$(TARGET_DIR) install