package/nvidia-driver: require kernel modules from Kconfig
authorYann E. MORIN <yann.morin.1998@free.fr>
Thu, 10 Dec 2015 18:53:15 +0000 (19:53 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 29 Dec 2015 22:51:44 +0000 (23:51 +0100)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/nvidia-driver/Config.in
package/nvidia-driver/nvidia-driver.mk

index b50e2c353a48dca3bc8722b3c9a299c1b5708176..30763c5a63eed3b889101b75a72ed86bd68e1413 100644 (file)
@@ -76,6 +76,7 @@ comment "nvidia kernel module needs a kernel to be built"
 config BR2_PACKAGE_NVIDIA_DRIVER_MODULE
        bool "nvidia kernel module"
        depends on BR2_LINUX_KERNEL
+       select BR2_LINUX_NEEDS_MODULES # not using kernel-module infra
        help
          Build the nvidia.ko kernel module.
 
index a021ab875b2f2214d7129d19b88973b5bf4bc1aa..7eef73b0fdf047ebc36d39968abd2345de223ea0 100644 (file)
@@ -91,10 +91,6 @@ ifeq ($(BR2_PACKAGE_NVIDIA_DRIVER_MODULE),y)
 
 NVIDIA_DRIVER_DEPENDENCIES += linux
 
-# We're building a kernel module without using the kernel-module infra,
-# so we need to tell we want module support in the kernel
-LINUX_NEEDS_MODULES = y
-
 # NVidia uses the legacy naming scheme for the x86 architecture, when i386
 # and x86_64 were still considered two separate architectures in the Linux
 # kernel.