mediastreamer: portaudio backend needs speex
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 19 Jun 2012 06:57:35 +0000 (08:57 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 19 Jun 2012 06:57:35 +0000 (08:57 +0200)
Fixes http://autobuild.buildroot.net/results/27996b33a6e3080f8d96204f5c1c421b17a86d6e

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/mediastreamer/mediastreamer.mk

index be91c44e78935b84ffb764ea4941bf780e0b2fc0..716a7334e885101aca14262b0374ae28da702d51 100644 (file)
@@ -12,9 +12,10 @@ else
 MEDIASTREAMER_CONF_OPT += --disable-alsa
 endif
 
-ifeq ($(BR2_PACKAGE_PORTAUDIO),y)
+# portaudio backend needs speex as well
+ifeq ($(BR2_PACKAGE_PORTAUDIO)$(BR2_PACKAGE_SPEEX),yy)
 MEDIASTREAMER_CONF_OPT += --enable-portaudio
-MEDIASTREAMER_DEPENDENCIES += portaudio
+MEDIASTREAMER_DEPENDENCIES += portaudio speex
 else
 MEDIASTREAMER_CONF_OPT += --disable-portaudio
 endif