package/nftables: use bundled mini-gmp without full-blown system gmp
authorAdrien Gallouët <adrien@gallouet.fr>
Fri, 17 Apr 2020 13:36:43 +0000 (13:36 +0000)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 19 Apr 2020 21:59:03 +0000 (23:59 +0200)
ntables bundles a mini implementation of gmp that can be used if the
system lacks the full-blown gmp.

Signed-off-by: Adrien Gallouët <adrien@gallouet.fr>
[yann.morin.1998@free.fr:
  - explicitly disable mini-gmp when full one is enabled
  - reword and expand commit log
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/nftables/Config.in
package/nftables/nftables.mk

index 6452ab4f52f71e73d2fd72e0037260dd82620d80..8d172b72569a222f5bd34df0e4640e9194ceacfd 100644 (file)
@@ -2,7 +2,6 @@ config BR2_PACKAGE_NFTABLES
        bool "nftables"
        depends on BR2_USE_WCHAR
        depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_12
-       select BR2_PACKAGE_GMP
        select BR2_PACKAGE_LIBMNL
        select BR2_PACKAGE_LIBNFTNL
        help
index 210e950c1150725fd98983a1c5db14a6e6e0db2e..1eef43586c6a21614cf73a47cb92b4515a47e822 100644 (file)
@@ -7,12 +7,19 @@
 NFTABLES_VERSION = 0.9.3
 NFTABLES_SOURCE = nftables-$(NFTABLES_VERSION).tar.bz2
 NFTABLES_SITE = https://www.netfilter.org/projects/nftables/files
-NFTABLES_DEPENDENCIES = gmp libmnl libnftnl host-bison host-flex \
+NFTABLES_DEPENDENCIES = libmnl libnftnl host-bison host-flex \
        host-pkgconf $(TARGET_NLS_DEPENDENCIES)
 NFTABLES_LICENSE = GPL-2.0
 NFTABLES_LICENSE_FILES = COPYING
 NFTABLES_CONF_OPTS = --disable-man-doc --disable-pdf-doc
 
+ifeq ($(BR2_PACKAGE_GMP),y)
+NFTABLES_DEPENDENCIES += gmp
+NFTABLES_CONF_OPTS += --without-mini-gmp
+else
+NFTABLES_CONF_OPTS += --with-mini-gmp
+endif
+
 ifeq ($(BR2_PACKAGE_READLINE),y)
 NFTABLES_DEPENDENCIES += readline
 NFTABLES_LIBS += -lncurses