gdk-pixbuf: don't update cache for static-only
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 25 Mar 2016 17:35:32 +0000 (14:35 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 25 Mar 2016 19:57:53 +0000 (20:57 +0100)
There won't be any need/files to scan for. Fixes:
http://autobuild.buildroot.net/results/5a7/5a7c158c8c2e49d5ca3b11ef3190cf0edd812ec5/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gdk-pixbuf/gdk-pixbuf.mk

index 02c4aa98c2ecf1cd9bbc821d3131ddec6a6d31a2..e77fd1540e38911d3444656ceb3cbea1c3a4f41e 100644 (file)
@@ -51,6 +51,7 @@ endif
 # here after building and installing to target.
 # And since the cache file will contain absolute target directory names
 # we need to sanitize (strip) them.
+ifeq ($(BR2_STATIC_LIBS),)
 define GDK_PIXBUF_UPDATE_CACHE
        GDK_PIXBUF_MODULEDIR=$(TARGET_DIR)/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders \
                $(HOST_DIR)/usr/bin/gdk-pixbuf-query-loaders \
@@ -59,6 +60,7 @@ define GDK_PIXBUF_UPDATE_CACHE
                $(TARGET_DIR)/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache
 endef
 GDK_PIXBUF_POST_INSTALL_TARGET_HOOKS += GDK_PIXBUF_UPDATE_CACHE
+endif
 
 # Tests don't build correctly with uClibc
 define GDK_PIXBUF_DISABLE_TESTS