mpir: fix build failure on MIPS
authorSemyon Kolganov <semenak94@mail.ru>
Fri, 21 Apr 2017 11:27:11 +0000 (14:27 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 1 May 2017 09:08:26 +0000 (11:08 +0200)
Fixes:

  http://autobuild.buildroot.net/results/3de0ef545a7303ec6564ecf1a1da3dd539957ed4/

Signed-off-by: Semyon Kolganov <semenak94@mail.ru>
[Thomas: remove bogus PowerPC stuff, fix n64 specification, rework
commit log.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mpir/mpir.mk

index 430d5874dc3c337bfbb59e2c1fe2c50df041a3ed..b7f38290078aa9672b7adb3c1444aa1fae2e10e4 100644 (file)
@@ -12,4 +12,12 @@ MPIR_LICENSE_FILES = COPYING.LIB
 MPIR_INSTALL_STAGING = YES
 MPIR_DEPENDENCIES = gmp host-yasm
 
+ifeq ($(BR2_MIPS_NABI32),y)
+MPIR_CONF_OPTS += ABI=n32
+endif
+
+ifeq ($(BR2_MIPS_NABI64),y)
+MPIR_CONF_OPTS += ABI=64
+endif
+
 $(eval $(autotools-package))