package/boost: stop on the first error during install to staging
authorRomain Naour <romain.naour@openwide.fr>
Fri, 15 May 2015 20:36:17 +0000 (22:36 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 16 May 2015 12:20:47 +0000 (14:20 +0200)
-q option is missing in BOOST_INSTALL_STAGING_CMDS,
so the build doesn't stop on the first error.
This help to see what happened.

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/boost/boost.mk

index 7060591411d093e31fea8066756887a58dd9d354..3fe44e3a7d374eeb20eaf7b7bc17e2993559d17c 100644 (file)
@@ -148,7 +148,7 @@ define HOST_BOOST_INSTALL_CMDS
 endef
 
 define BOOST_INSTALL_STAGING_CMDS
-       (cd $(@D) && ./bjam -j$(PARALLEL_JOBS) -d+1 \
+       (cd $(@D) && ./bjam -j$(PARALLEL_JOBS) -q -d+1 \
        --user-config=$(@D)/user-config.jam \
        $(BOOST_OPTS) \
        --prefix=$(STAGING_DIR)/usr \