imx-vpu: bump to version 5.4.35
authorGary Bisson <gary.bisson@boundarydevices.com>
Tue, 1 Nov 2016 16:09:59 +0000 (17:09 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 1 Nov 2016 18:27:43 +0000 (19:27 +0100)
Changelog:
Coverity fixes for resources leaks, null dereference, string overflows
and checking return.

This patch is based on the Yocto equivalent:
https://github.com/Freescale/meta-freescale/commit/b138b5b0

Implicitly tested through gstreamer as the plugins rely on it:
 # gst-launch-1.0 playbin uri=file:///root/tears_of_steel_1080p.webm
 # gst-launch-1.0 filesrc location=/root/tears_of_steel_1080p.webm ! \
       matroskademux ! imxvpudec ! imxipuvideosink

Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/freescale-imx/imx-vpu/imx-vpu.hash
package/freescale-imx/imx-vpu/imx-vpu.mk

index 67ebaf23140e813899db651a4463dc3a355412cd..b3d617ded9d22163f377257f5fd8ac4959771ed6 100644 (file)
@@ -1,2 +1,2 @@
 # Locally computed
-sha256 2e670ef2337a5dbe6c32fa07128ad9aad32afdbf472c23d44133245ec6a66d46  imx-vpu-5.4.33.bin
+sha256 e1d6550426dfc59e4fd0352f1d312ea7eff5dcf18974f923ed7a85007cb40e27  imx-vpu-5.4.35.bin
index 09ff5a80a6e06136c859bdc5606881f74f1e37e2..0b464d854dee0081840dc3d4e957fda8c66c3c36 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-IMX_VPU_VERSION = 5.4.33
+IMX_VPU_VERSION = 5.4.35
 IMX_VPU_SITE = $(FREESCALE_IMX_SITE)
 IMX_VPU_SOURCE = imx-vpu-$(IMX_VPU_VERSION).bin