package/raspi-gpio: new package
authorPierre-Jean Texier <pjtexier@koncepto.io>
Tue, 12 Nov 2019 21:22:29 +0000 (22:22 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 19 Nov 2019 16:37:47 +0000 (17:37 +0100)
Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io>
[Thomas: fix typo in Config.in, disable installation to staging, both
were noticed by Yann E. Morin]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/raspi-gpio/Config.in [new file with mode: 0644]
package/raspi-gpio/raspi-gpio.hash [new file with mode: 0644]
package/raspi-gpio/raspi-gpio.mk [new file with mode: 0644]

index 19ea83df3b6802c4a834771863c9ff16f63615bf..1d3dcc1f5d332b314fce8525d9f7c34f9ff1dab1 100644 (file)
@@ -1949,6 +1949,7 @@ F:        package/libxml2/
 F:     package/mongoose/
 F:     package/mxml/
 F:     package/python-periphery/
+F:     package/raspi-gpio/
 F:     package/sbc/
 F:     package/stunnel/
 F:     package/tree/
index 36d2b31e2e81800e98cac3d20f938b468f6e7fb5..c2b48a6cbe54bf49ea41e2cd477b5c27f5b23d50 100644 (file)
@@ -510,6 +510,7 @@ endmenu
        source "package/pps-tools/Config.in"
        source "package/pru-software-support/Config.in"
        source "package/pulseview/Config.in"
+       source "package/raspi-gpio/Config.in"
        source "package/read-edid/Config.in"
        source "package/rng-tools/Config.in"
        source "package/rpi-userland/Config.in"
diff --git a/package/raspi-gpio/Config.in b/package/raspi-gpio/Config.in
new file mode 100644 (file)
index 0000000..32a9448
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_RASPI_GPIO
+       bool "raspi-gpio"
+       help
+         Tool to help debug / hack at the BCM283x GPIO. You can dump
+         the state of a GPIO or (all GPIOs). You can change a GPIO
+         mode and pulls (and level if set as an output).
+
+         Beware this tool writes directly to the BCM283x GPIO
+         registers, ignoring anything else that may be using them
+         (like Linux drivers).
+
+         https://github.com/RPi-Distro/raspi-gpio
diff --git a/package/raspi-gpio/raspi-gpio.hash b/package/raspi-gpio/raspi-gpio.hash
new file mode 100644 (file)
index 0000000..8a808b6
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256 8f3fb411746d339d69adc398497892883c11d2d715ccbe6d8b0b5a401da73bd5  raspi-gpio-2eaa8b8755a550e34d07c898b90b0d9b3d66fd81.tar.gz
+sha256 6e02227e1fb942687163996678d94add7911890c50025912d0ae7ee66d256bb2  LICENSE
diff --git a/package/raspi-gpio/raspi-gpio.mk b/package/raspi-gpio/raspi-gpio.mk
new file mode 100644 (file)
index 0000000..f841c98
--- /dev/null
@@ -0,0 +1,12 @@
+################################################################################
+#
+# raspi-gpio
+#
+################################################################################
+
+RASPI_GPIO_VERSION = 2eaa8b8755a550e34d07c898b90b0d9b3d66fd81
+RASPI_GPIO_SITE = $(call github,RPi-Distro,raspi-gpio,$(RASPI_GPIO_VERSION))
+RASPI_GPIO_LICENSE = BSD-3-Clause
+RASPI_GPIO_LICENSE_FILES = LICENSE
+
+$(eval $(autotools-package))