python-wrapt: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Fri, 12 Oct 2018 08:06:48 +0000 (10:06 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 30 Oct 2018 20:09:57 +0000 (21:09 +0100)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Reviewed-by: Asaf Kahlon <asafka7@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/python-wrapt/Config.in [new file with mode: 0644]
package/python-wrapt/python-wrapt.hash [new file with mode: 0644]
package/python-wrapt/python-wrapt.mk [new file with mode: 0644]

index 50005cdb70c56b1046e78b287e7de9f780b14892..94e19e4a191cc11b37bc7e4a730144426e403dac 100644 (file)
@@ -1058,6 +1058,7 @@ menu "External python modules"
        source "package/python-websockets/Config.in"
        source "package/python-werkzeug/Config.in"
        source "package/python-whoosh/Config.in"
+       source "package/python-wrapt/Config.in"
        source "package/python-ws4py/Config.in"
        source "package/python-wsaccel/Config.in"
        source "package/python-xlib/Config.in"
diff --git a/package/python-wrapt/Config.in b/package/python-wrapt/Config.in
new file mode 100644 (file)
index 0000000..da315c9
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PYTHON_WRAPT
+       bool "python-wrapt"
+       help
+         Module for decorators, wrappers and monkey patching.
+
+         https://github.com/GrahamDumpleton/wrapt
diff --git a/package/python-wrapt/python-wrapt.hash b/package/python-wrapt/python-wrapt.hash
new file mode 100644 (file)
index 0000000..dbf8932
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/wrapt/json
+md5    e1346f31782d50401f81c2345b037076  wrapt-1.10.11.tar.gz
+sha256 d4d560d479f2c21e1b5443bbd15fe7ec4b37fe7e53d335d3b9b0a7b1226fe3c6  wrapt-1.10.11.tar.gz
+# Locally computed sha256 checksums
+sha256 b6d2e5d228202a11bc5e5988661fc5d8acc1ba4f27256c37e19029131a30b1f2  LICENSE
diff --git a/package/python-wrapt/python-wrapt.mk b/package/python-wrapt/python-wrapt.mk
new file mode 100644 (file)
index 0000000..dd8b9a5
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-wrapt
+#
+################################################################################
+
+PYTHON_WRAPT_VERSION = 1.10.11
+PYTHON_WRAPT_SOURCE = wrapt-$(PYTHON_WRAPT_VERSION).tar.gz
+PYTHON_WRAPT_SITE = https://files.pythonhosted.org/packages/a0/47/66897906448185fcb77fc3c2b1bc20ed0ecca81a0f2f88eda3fc5a34fc3d
+PYTHON_WRAPT_SETUP_TYPE = distutils
+PYTHON_WRAPT_LICENSE = BSD-2-Clause
+PYTHON_WRAPT_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))