python-systemd: add new package
authorAndrey Smirnov <andrew.smirnov@gmail.com>
Mon, 17 Jul 2017 21:07:50 +0000 (14:07 -0700)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 20 Jul 2017 21:08:43 +0000 (23:08 +0200)
Add package for official python bindings availibe as a part of systemd
project at: https://github.com/systemd/python-systemd

Minimal config snippet for utils/test-pkg is as follows (sans
backslashes):

BR2_INIT_SYSTEMD=y
BR2_PACKAGE_PYTHON3=y
BR2_PACKAGE_PYTHON_SYSTEMD=y

Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/python-systemd/Config.in [new file with mode: 0644]
package/python-systemd/python-systemd.hash [new file with mode: 0644]
package/python-systemd/python-systemd.mk [new file with mode: 0644]

index 53a0bbaf079f7c540332a2586dfd0b09aa2b972f..7b7c5ab4e6792ff723c33262896a654ab6d7416c 100644 (file)
@@ -98,6 +98,7 @@ F:    package/python-pathlib2/
 F:     package/python-pickleshare/
 F:     package/python-scandir/
 F:     package/python-simplegeneric/
+F:     package/python-systemd/
 F:     package/python-traitlets/
 
 N:     Andrey Yurovsky <yurovsky@gmail.com>
index 1775fc16264ded78d42b42bb92d452b1dadd8da9..7bb9471670f0398ed2eb3980afa25798cd6cb8c3 100644 (file)
@@ -863,6 +863,7 @@ menu "External python modules"
        source "package/python-socketio/Config.in"
        source "package/python-sortedcontainers//Config.in"
        source "package/python-spidev/Config.in"
+       source "package/python-systemd/Config.in"
        source "package/python-tempora/Config.in"
        source "package/python-typepy/Config.in"
        source "package/python-thrift/Config.in"
diff --git a/package/python-systemd/Config.in b/package/python-systemd/Config.in
new file mode 100644 (file)
index 0000000..599b43f
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_PYTHON_SYSTEMD
+       bool "python-systemd"
+       depends on BR2_PACKAGE_SYSTEMD
+       help
+         Python module for native access to the systemd facilities.
+
+         https://github.com/systemd/python-systemd
+
+comment "python-systemd needs systemd"
+       depends on !BR2_PACKAGE_SYSTEMD
diff --git a/package/python-systemd/python-systemd.hash b/package/python-systemd/python-systemd.hash
new file mode 100644 (file)
index 0000000..a645bec
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/systemd-python/, sha256 locally computed
+md5 8438acab31e6f1e3e963d36f3de62faa systemd-python-233.tar.gz
+sha256 06a3768b744884565d7961b44f4a51d164765bc59692f0f85ea6f11330a17da4 systemd-python-233.tar.gz
diff --git a/package/python-systemd/python-systemd.mk b/package/python-systemd/python-systemd.mk
new file mode 100644 (file)
index 0000000..242a2ea
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# python-systemd
+#
+################################################################################
+
+PYTHON_SYSTEMD_VERSION = 233 # Should be kept in sync with $(SYSTEMD_VERSION)
+PYTHON_SYSTEMD_SOURCE = systemd-python-$(PYTHON_SYSTEMD_VERSION).tar.gz
+PYTHON_SYSTEMD_SITE = https://pypi.python.org/packages/10/89/d66ae73bdbc2614e4f2e90ddf9ef80d22c28f3cd70071345c3640465c14c
+PYTHON_SYSTEMD_SETUP_TYPE = distutils
+PYTHON_SYSTEMD_LICENSE = LGPL-2.1
+PYTHON_SYSTEMD_LICENSE_FILES = LICENSE.txt
+PYTHON_SYSTEMD_DEPENDENCIES = systemd # To be able to link against libsystemd
+
+$(eval $(python-package))