toolchain-external: install libanl.so for glibc
authorJesper Baekdahl <jbb@gamblify.com>
Fri, 24 Feb 2017 09:03:08 +0000 (10:03 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 24 Feb 2017 11:02:29 +0000 (12:02 +0100)
libanl.so is needed for asynchronous network address and service
translation, declared in netdb.h

Signed-off-by: Jesper Bækdahl <jbb@gamblify.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/toolchain-external/pkg-toolchain-external.mk

index 6658875007302082864304b4c37b36ca909d04c2..11a1bf5e24920903f1753b4cc8a8312b86972713 100644 (file)
@@ -124,7 +124,7 @@ endif # ! no threads
 endif
 
 ifeq ($(BR2_TOOLCHAIN_EXTERNAL_GLIBC),y)
-TOOLCHAIN_EXTERNAL_LIBS += libnss_files.so.* libnss_dns.so.* libmvec.so.*
+TOOLCHAIN_EXTERNAL_LIBS += libnss_files.so.* libnss_dns.so.* libmvec.so.* libanl.so.*
 endif
 
 ifeq ($(BR2_TOOLCHAIN_EXTERNAL_MUSL),y)