libimxvpuapi: bump version to 0.10.2
authorAndrew Webster <awebster@arcx.com>
Fri, 10 Jun 2016 18:13:39 +0000 (14:13 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 15 Jun 2016 20:48:40 +0000 (22:48 +0200)
Changelog:
- fix AUD NAL positioning in h.264 encoder output
  (SPS/PPS/AUD were ordered incorrectly - AUD has to come first, not last)
- fix build error with examples when --enable-static is used
- pass quality factor in simplified JPEG encoder interface correctly
- add functions for querying and setting header data
  useful for modifying headers, like VUI data in the SPS RBSP
- documentation updates

This patch is based on the Yocto equivalent:
https://github.com/Freescale/meta-fsl-arm/commit/c999668

Implicitly tested through gstreamer as the plugin relies on it:
 # gst-launch-1.0 playbin uri=file:///root/tears_of_steel_1080p.webm

Signed-off-by: Andrew Webster <awebster@arcx.com>
Reviewed-by: Gary Bisson <gary.bisson@boundarydevices.com>
Tested-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libimxvpuapi/libimxvpuapi.hash
package/libimxvpuapi/libimxvpuapi.mk

index fd90a20564a1ba3fed1cafa6140b87b5a514f41e..c8cabcf285d4b8607e881a31ed337279469386f7 100644 (file)
@@ -1,2 +1,2 @@
 # locally computed hash
-sha256 8d7aeed88c06fda44318cef9565ae47b86461bd309908b1103a7974ed0822a8d  libimxvpuapi-0.10.1.tar.gz
+sha256 8e6dc4105db6164c0de72fd60eb73f4ba1632f7ba5052b1abc834b462b566da2  libimxvpuapi-0.10.2.tar.gz
index e0d8cc981f8f273016e4766cd9ecf1ed51108cc8..df84806234f94ad2b01cf5ce1e85a7719ab28d24 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBIMXVPUAPI_VERSION = 0.10.1
+LIBIMXVPUAPI_VERSION = 0.10.2
 LIBIMXVPUAPI_SITE = $(call github,Freescale,libimxvpuapi,$(LIBIMXVPUAPI_VERSION))
 LIBIMXVPUAPI_LICENSE = LGPLv2.1+
 LIBIMXVPUAPI_LICENSE_FILES = LICENSE