package/systemd: explicitly configure split-usr=false and split-bin=true
authorAlexander Sverdlin <alexander.sverdlin@gmail.com>
Sun, 11 Nov 2018 15:06:52 +0000 (16:06 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 11 Nov 2018 20:55:10 +0000 (21:55 +0100)
meson-based build of systemd runs a couple of checks on the structure
of the *host* system which will incorrectly configure systemd if build
host configuration doesn't match Buildroot target.

One can also find the following in the NEWS file:

* A new -Dsplit-bin= build configuration switch may be used to specify
  whether bin and sbin directories are merged, or if they should be
  included separately in $PATH and various listings of executable
  directories. The build configuration scripts will try to autodetect
  the proper values of -Dsplit-usr= and -Dsplit-bin= based on build
  system, but distributions are encouraged to configure this
  explicitly.

Signed-off-by: Alexander Sverdlin <alexander.sverdlin@gmail.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/systemd/systemd.mk

index 48134966707afd8f6d80d14efef9958deec0de82..ecbf7e97ffb1f1acddb0a0e267cea3b3607ea012 100644 (file)
@@ -29,6 +29,8 @@ SYSTEMD_CONF_OPTS += \
        -Dldconfig=false \
        -Ddefault-dnssec=no \
        -Dtests=false \
+       -Dsplit-bin=true \
+       -Dsplit-usr=false \
        -Dsystem-uid-max=999 \
        -Dsystem-gid-max=999 \
        -Dtelinit-path=$(TARGET_DIR)/sbin/telinit \