boost: add option to build boost_coroutine
authorEdson Siqueira <edson.siqueira@datacom.ind.br>
Tue, 3 Nov 2015 16:59:38 +0000 (14:59 -0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 3 Nov 2015 20:16:26 +0000 (21:16 +0100)
It was disabled by default by commit
611dfe6cb55ed72d7df3b7c102f4a723248a4037 because it caused some build
failures on AArch64 and SuperH. However, the coroutine module needs
the context module, which is only available on certain architectures.

We can therefore allow enabling the coroutine module, but only if the
context module is available.

[Thomas: extend commit log with more details.]

Signed-off-by: Edson Siqueira <edson.siqueira@datacom.ind.br>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/boost/Config.in
package/boost/boost.mk

index ac701524f91b5b64368f0f4101d7ac5597860845..150174cd8a1b92c284ee288ce4743203cfd17017 100644 (file)
@@ -70,6 +70,10 @@ config BR2_PACKAGE_BOOST_CONTEXT
        depends on (BR2_arm || BR2_armeb || BR2_i386 || BR2_mips || BR2_mipsel \
                        || BR2_powerpc || BR2_sparc || BR2_x86_64)
 
+config BR2_PACKAGE_BOOST_COROUTINE
+        bool "boost-coroutine"
+        depends on BR2_PACKAGE_BOOST_CONTEXT
+
 config BR2_PACKAGE_BOOST_DATE_TIME
        bool "boost-date_time"
 
index 16d05cd99bdad5d4059c46a09df844ced1b11bf3..80325b0a4e2fd9225d9450f2ec9d0d29ffa5b0cb 100644 (file)
@@ -20,13 +20,11 @@ HOST_BOOST_FLAGS = --without-icu \
        iostreams locale log math mpi program_options python random regex \
        serialization signals system test thread timer wave)
 
-# coroutine breaks on some weak toolchains and it's new for 1.54+
-BOOST_WITHOUT_FLAGS = coroutine
-
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_ATOMIC),,atomic)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CHRONO),,chrono)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CONTAINER),,container)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CONTEXT),,context)
+BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_COROUTINE),,coroutine)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_DATE_TIME),,date_time)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_EXCEPTION),,exception)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_FILESYSTEM),,filesystem)