package/gtest: add and install a .pc file
authorYann E. MORIN <yann.morin@orange.com>
Thu, 23 Jun 2016 07:09:35 +0000 (09:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 24 Jun 2016 16:00:01 +0000 (18:00 +0200)
Signed-off-by: "Yann E. MORIN" <yann.morin@orange.com>
Signed-off-by: Cedric Chedaleux <cedric.chedaleux@orange.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gtest/gtest.mk
package/gtest/gtest.pc [new file with mode: 0644]

index da08621029e2df99e3fe4d9c94484a86cbde88d5..a4ef45beb111bd089877b417c5c617682d2a2548 100644 (file)
@@ -31,6 +31,8 @@ define GTEST_INSTALL_STAGING_CMDS
        $(INSTALL) -D -m 0755 $(@D)/libgtest_main.a $(STAGING_DIR)/usr/lib/libgtest_main.a
        $(INSTALL) -d -m 0755 $(STAGING_DIR)/usr/include/gtest/
        cp -rp $(@D)/include/gtest/* $(STAGING_DIR)/usr/include/gtest/
+       $(INSTALL) -D -m 0644 packages/gtest/gtest.pc \
+               $(STAGING_DIR)/usr/lib/pkgconfig/gtest.pc
        # Generate the gtest-config script manually, since the CMake
        # build system is not doing it.
        sed 's%@PACKAGE_TARNAME@%gtest%;\
diff --git a/package/gtest/gtest.pc b/package/gtest/gtest.pc
new file mode 100644 (file)
index 0000000..b7a8aa4
--- /dev/null
@@ -0,0 +1,11 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${prefix}/lib/
+includedir=${prefix}/include
+
+Name: gtest
+Description: Google C++ Testing Framework
+Version: 1.7.0
+Libs: -L${libdir} -lgtest
+Libs.private: -lpthread
+Cflags: -I${includedir}