linux: add option to select the CIP real-time kernel
authorAngelo Compagnucci <angelo.compagnucci@gmail.com>
Tue, 26 Nov 2019 11:59:33 +0000 (12:59 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 26 Nov 2019 21:55:10 +0000 (22:55 +0100)
This patch adds Linux CIP RT, the PREEMPT_RT real-time variant maintained
by the CIP team.

Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
linux/Config.in
linux/linux.mk

index 8c5539c9ab6a10b8c40e224f0b7176b047598fab..eacd53dafb081e4a33740a34bbabab1699646c49 100644 (file)
@@ -53,6 +53,17 @@ config BR2_LINUX_KERNEL_LATEST_CIP_VERSION
 
          https://www.cip-project.org
 
+config BR2_LINUX_KERNEL_LATEST_CIP_RT_VERSION
+       bool "Latest CIP RT SLTS version (4.19.72-cip10-rt4)"
+       help
+         Same as the CIP version, but this is the PREEMPT_RT realtime
+         variant.
+
+         The CIP community plans to maintain 4.19 for security and
+         bug fixes for more than 10 years.
+
+         https://www.cip-project.org
+
 config BR2_LINUX_KERNEL_CUSTOM_VERSION
        bool "Custom version"
        help
@@ -124,6 +135,7 @@ config BR2_LINUX_KERNEL_VERSION
        string
        default "5.3.8" if BR2_LINUX_KERNEL_LATEST_VERSION
        default "4.19.82-cip14" if BR2_LINUX_KERNEL_LATEST_CIP_VERSION
+       default "4.19.72-cip10-rt4" if BR2_LINUX_KERNEL_LATEST_CIP_RT_VERSION
        default BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE \
                if BR2_LINUX_KERNEL_CUSTOM_VERSION
        default "custom" if BR2_LINUX_KERNEL_CUSTOM_TARBALL
index c45db4d24ff2ab6302dbf6b74578df718c6d04cb..762f8868b19c470dece261c8421364ac771ce1d6 100644 (file)
@@ -29,7 +29,7 @@ LINUX_SITE_METHOD = hg
 else ifeq ($(BR2_LINUX_KERNEL_CUSTOM_SVN),y)
 LINUX_SITE = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_REPO_URL))
 LINUX_SITE_METHOD = svn
-else ifeq ($(BR2_LINUX_KERNEL_LATEST_CIP_VERSION),y)
+else ifeq ($(BR2_LINUX_KERNEL_LATEST_CIP_VERSION)$(BR2_LINUX_KERNEL_LATEST_CIP_RT_VERSION),y)
 LINUX_SOURCE = linux-cip-$(LINUX_VERSION).tar.gz
 LINUX_SITE = https://git.kernel.org/pub/scm/linux/kernel/git/cip/linux-cip.git/snapshot
 else ifneq ($(findstring -rc,$(LINUX_VERSION)),)